分类目录归档:WP-QINIU插件

WP-QINIU更新(V2.0.2)

更新内容(2.0.1更新时未发说明,本次一起说明):

2018-07-07
V2.0.2
1、修改了上传文件成功后的文件信息提交模式,由七牛服务器回调改为由客户端在文件上传成功后直接提交,解决部分用户七牛服务器回调失败的问题。

2018-07-03
V2.0.1
1、增加双击文件图标,可复制文件访问地址到剪贴板中的功能。
2、增加添加上传文件后,显示“开始上传”或“暂停上传”按钮,可手动开始或暂停上传。
3、修复了在编辑文件插入图片界面,不能上传文件的bug。

其他说明:
        因部分网友反应文件上传失败,报错误码为0,后经确认为wordpress站点启用了https,而七牛未启用https,造成浏览器认为存在跨域访问被禁止,此问题可以通过浏览器设置允许访问,或启用七牛的https支持解决。

插件下载地址:

wordpress官网下载https://wordpress.org/plugins/wp-qiniu/
GitHub下载https://github.com/wishinlife/wp-qiniu

WP-QINIU更新(V2.0.0)

更新内容:

2018-06-26
v2.0.0
* 1、七牛JS SDK升级到2.3.0版。
* 2、可自动根据bucket查询上传服务器地址,可支持华东、华北、华南、北美、新加坡区域存储。
* 3、开启https支持时,上传文件也同步采用https协议。

插件下载地址:

wordpress官网下载https://wordpress.org/plugins/wp-qiniu/
GitHub下载https://github.com/wishinlife/wp-qiniu

WP-QINIU更新(V1.6.1)

更新内容:

2018-06-18
v1.6.1
1、七牛PHP SDK升级到7.2.6版。
2、七牛JS SDK升级到1.0.24版,解决了使用非华东机房的空间报错问题,七牛官方说明在1.0.19版中已解决,已测试可以解决。
3、增加七牛云存储https支持,需在设置中勾选“存储空间已开启 HTTPS”并保存(图片文件只对修改后插入文章的才生效,使用短代码的保存后即时生效)。

其他:
七牛官方的JS SDK已升级到2.3.0,但版本2改动很大,基本是如要把整个文件上传部分重新,暂时时间有限,把JS SDK升级到版本1的最后一个版本,解决部分问题,有时间了再考虑升级到版本2.

       不少网友反应,上传文件报”文件上传成功,但回调失败“,因我这测试一致无法再现此问题,因此不知道这个问题的具体原因,七牛官方说sdk支持php5.3及以上,也支持php7,如果版本较低的话肯定是不行的,另外本次升级针对此问题也做了一点处理,不知道是否有效,如果有网友有这问题,升级后解决了,还请及时告诉我,好写个说明,提示有此问题的网友升级下。

插件下载地址:

wordpress官网下载https://wordpress.org/plugins/wp-qiniu/
GitHub下载https://github.com/wishinlife/wp-qiniu

WP-QINIU发布

最近闲来写了各小插件,用于wordpress直连外部存储做图床的,之前基于wp2pcs改了一个wp2pcs-sy可以连接百度网盘,访问图片、视频、音乐等,但后面不能用了,我看不少人有这个需求,同时自己也有一点小小的需求。考察了下百度的对象存储、阿里云的对象存储和七牛的对象存储,价格都差异不大,只有七牛的有10G的免费空间和流量,就做了个七牛的,谁叫咱爱用免费的。写这个之前也搜了一番,看有没有七牛的插件,只搜到一个七牛镜像存储插件,我这wordpress是在bae上,不是独立的主机,上传的图片一重启就没有,所以没法用,这才自己写了这个直连七牛云存储的插件。好了,不多说了,分别上一个图片、音频、视频的示例吧。

screenshot-1.png

 

 

七牛还有些扩展功能,能压缩图片,给图片加水印,且不收费,还具有原图保护、防盗链等功能。

插件下载地址:

wordpress官网下载https://wordpress.org/plugins/wp-qiniu/
GitHub下载https://github.com/wishinlife/wp-qiniu

 

======================================================================

2018-6-17

近来比较忙,也没什么时间上来看,今天上来看了下,不少童鞋反应上传完文件后,提示上传成功但回调失败的问题,我特意上传了一张照片看了下,我这都正常的,不知道这个跟主机或php版本有没有什么关系,如有此问题还请注意下php版本,最好是在5.5或以上,七牛官方说的sdk需求的最低版本是5.3以上。

我近期也抽点时间,看看官方sdk有没有更新,有的话也同步更新下,另外增加下https的支持,毕竟七牛早已支持https了。