SyncY更新(Python 1.0.17)

修改内容:

1、修复了当达到预设更新token的时间后启动应用程序,导致出错退出的bug。
2、修复了当未能正确获取最新程序版本时,程序出错退出的bug。
3、增加了下载文件后,新文件的权限按照父文件夹的权限减去执行权限设置(新建的文件夹权限与父文件夹权限相同)。

luci版升级的,如不想重新绑定及设置同步目录,请先备份/etc/config/syncy文件,安装完之后恢复此文件。非luci版的,直接替换syncy.py文件

进入下载页面

SyncY更新(Python 1.0.17)》上有3条评论

  1. Sing

    你好,启动失败。这些错误是什么意思?

    Traceback (most recent call last):
    File “/usr/bin/syncy.py”, line 1383, in
    sy = SyncY(sys.argv[1:])
    File “/usr/bin/syncy.py”, line 226, in __init__
    self.__check_expires()
    File “/usr/bin/syncy.py”, line 271, in __check_expires
    m = self._re[‘uid’].findall(self._response_str)
    AttributeError: SyncY instance has no attribute ‘_re’
    Traceback (most recent call last):
    File “/usr/bin/syncy.py”, line 1383, in
    sy = SyncY(sys.argv[1:])
    File “/usr/bin/syncy.py”, line 226, in __init__
    self.__check_expires()
    File “/usr/bin/syncy.py”, line 271, in __check_expires
    m = self._re[‘uid’].findall(self._response_str)
    AttributeError: SyncY instance has no attribute ‘_re’
    Traceback (most recent call last):
    File “/usr/bin/syncy.py”, line 1383, in
    sy = SyncY(sys.argv[1:])
    File “/usr/bin/syncy.py”, line 226, in __init__
    self.__check_expires()
    File “/usr/bin/syncy.py”, line 271, in __check_expires
    m = self._re[‘uid’].findall(self._response_str)
    AttributeError: SyncY instance has no attribute ‘_re’

    回复
    1. WishInLife 文章作者

      你好,1.0.17版这个地方有个bug,你可以安装2.0.0版,但2.0.0版现在线程不能开多了,开2个还行,多了容易出错,过两天发个更新后就可以开更多个线程。

      回复

发表评论

电子邮件地址不会被公开。 必填项已用*标注